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Abstract 
The teaching of colours mixing is one of the activities carried out in all preschools and primary 
schools. There are many activities with colours and/or colours mixing that can be explored in the 
classroom. These activities provide the first contact of children with colour theory and can have an 
important role in the formation of scientific concepts. However, the generality of the activities fit into 
teaching by mixing the primary colours of paints (not always taught correctly) so as to get the 
secondary colours. The students begin to learn the basics of colour theory based mainly on the 
subtractive colour model, which can lead to several misconceptions concerning the concept of colour. 
Many of these misleading ideas about colour persist into adulthood and can be found even in 
university physics students. A very common misconception is that mixing the same colours using 
lights or pigments will give the same result. Therefore, it is important to develop appropriate learning 
activities which can allow students to explore additive colour mixing through the mixing of coloured 
lights as well as understand that the primary colours of light (red, blue and green) are different from 
the primary colours of pigments (cyan, magenta and yellow). These activities should also allow 
students to see that white light is actually made up of all of the colours of the rainbow and help them to 
understand how we perceive colour. 

In this work we start from the knowledge that the colour of an object is most often the result of 
absorption or subtraction of certain parts of the visible spectrum, through selective reflection or 
selective transmission of the remaining parts of the spectrum, to explore some illustrative and intuitive 
activities. These activities will allow students to explore white light decomposition, additive colour 
mixing and subtractive colour mixing (either using paints or coloured filters). Some of the proposed 
activities are based on the exploration of some recently published children’s books whose coloured 
images are created using a technique that revealed different images under different lights (RGB art) 
e.g. [1-7]. Each image is made by three different layers, each of them containing either a cyan, a 
magenta or a yellow image. Using a set of coloured filters (usually red, green and blue filters) that 
come with the books it is possible to see clearly the layers that compose the image. Students are 
invited to make draws using different colours and using coloured filters see how the draws change 
when illuminated by different colour lights. These activities will help students to understand that colour 
is not an intrinsic property of an object and it depends not only on the physical properties of the object 
but also on the characteristics of light that illuminates the object and on the human visual system. The 
work presented explores a script of activities designed to be used by teachers of preschool and 
primary education. 

Keywords: Additive and subtractive colour mixing, primary and secondary colours, visible light 
spectrum, didactic activities, RGB art. 

1 INTRODUCTION  
We all begin to learn about colours very early in our childhood. The teaching of subtractive colours 
mixing is one of the activities carried out in all preschools and primary schools. However many 
students find colour phenomena a difficult subject and fail to explain them based on adequate 
scientific concepts. This difficulty can be found not only in primary school students but also among 
pre-college and college students who have had a formal instruction in introductory optics covering 
topics of geometrical optics like light propagation, light and shadows, reflection, refraction, image 
formation with mirror and lenses, colour addition and subtraction. Although students are mostly able to 
apply the laws of subtractive colour mixing, many of them fail to recognized the primary subtractive 
colours as cyan, magenta and yellow and only a few are able to identify the primary colours of light 
and correctly apply the laws of additive colour mixing. But the most difficult and challenging task for 
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students is to explain how we perceived colour in particular when objects are illuminated with other 
than white light sources. 

In order to address student’s difficulties regarding colour phenomena and to design effective learning 
activities it is important for teachers to be aware of the many deeply rooted common sense 
preconceptions held by students. Several investigations [8], [9], [10] have identified and analysed 
student’s misconceptions regarding light and colour phenomena and they show that certain 
misconceptions are held by a large number of students and also that these misconceptions persist 
beyond conventional instruction.    

Students’ concepts concerning colour phenomena begin to develop very early in their childhood and 
are mainly determined by their everyday experiences. Therefore it is important to design oriented 
experimental activities which can allow preschool and primary school children to develop adequate 
ideas concerning colour phenomena. 

In this article we propose some activities related with additive and subtractive colour mixing that can 
be carried out in the classroom with preschools and primary schools pupils. Some of the activities 
suggested are based on the exploration of some children’s books whose coloured images can change 
through the interaction between pigments and light [1], [2], [3], [4], [5], [6], [7]. These activities facilitate 
the experience of seeing coloured objects illuminated with other than white light sources and support 
students in understanding the relevance of the illuminating light in the perception of colour and the 
concept of selective reflection for colour objects. 

2 METHODOLOGY 

2.1 Additive Colour Mixing 
To fully understand the processes underlying colour formation students should be able to describe 
white light as addition of spectral or primary colours (red, green and blue) [9]. The colour composition 
of white light can be demonstrated by using a glass or plastic prism or a diffraction grating to 
separated white light in their spectral components. Children can also make simple spectroscopes in 
the classroom using a cardboard box and a diffraction grating or a piece of a CD (compact disk). Then 
they can use the spectroscopes to observe, describe and compare the spectrum (colours) emitted by 
different light sources (white and coloured light sources). 

The generality of the activities related with colour mixing that are carried out in preschools and primary 
schools involves the mixing of paints, usually watercolours and gouaches. Children begin to learn the 
basics of colour theory based on the subtractive colour model, which can lead them to develop 
scientifically incorrect ideas concerning colour phenomena. Most students have difficulties in 
predicting and explaining the results from mixing coloured lights because their predictions are based 
on their knowledge about mixing coloured pigments. They labour under the misconception that 
coloured lights mixtures follows the same rules as the mixtures of paints. However, in order to develop 
scientifically adequate ideas about colour perception students should understand the principles of 
additive colour mixing, because the colour in which we perceive an object results from the mixing of 
different colours of light. Therefore, it is important to develop appropriate learning activities which can 
allow students to explore additive colour mixing through the mixing of coloured lights as well as 
understand that the primary colours of light (red, blue and green) are different from the primary colours 
of pigments (cyan, magenta and yellow). The mixing of coloured lights can be investigated in the 
classroom in various ways. By playing with three flashlights with similar light intensities and coloured 
filters of the three primary colours children can learn that coloured light can be mixed to create other 
coloured lights (the secondary colours of light, cyan, magenta and yellow) or white light. The teachers 
can also use the PhET Color Vision Simulation (University of Colorado) [11] to demonstrate to children 
that it’s possible to create light colours other than cyan, magenta and yellow only by mixing red, green 
and blue lights with different intensities. 

Creating coloured shadows in another way of learning about additive colour mixing. With red, green, 
and blue light bulbs children can make shadows of seven different colors, blue, red, green, black, 
cyan, magenta, and yellow, by blocking different combinations of lights, as shown in Fig.1. When we 
block two lights we see a shadow of the third colour. For example, blocking the red and green lights, 
we get a green shadow. If only one of the lights are blocked, we get a shadow whose colour results 
from the mixture of the other two. Blocking the red light, we get a cyan shadow resulting from the 
mixture of green and blue lights; blocking the green light, we get a magenta shadow resulting from the 
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mixture of red and blue lights; blocking the blue light, we get a yellow shadow resulting from the 
mixture of red and green lights. If all the lights are blocked, we get a black shadow. 

 
Figure 1. Coloured shadows created by using light bulbs of the three primary colours. 

2.2 Subtractive Colour Mixing 
A complete understanding of colour perception also requires an understanding of the principles of 
colour subtraction. Mixing pigment colours or filters is a colour subtraction process. Each pigment or 
filter absorbs or subtracts certain colours of light from the visible spectrum through selective reflection 
or selective transmission of the remaining colours of the spectrum. Only the light colours that are 
reflected by all of the pigments or that can pass through all of the filters and reaches our eyes 
determine the perceived colour. 

There are many activities that can be carried out in the classroom to allow students to discover and 
explore colour subtraction. For instance, children can use pieces of cyan, magenta and yellow filters 
taped on a sheet of white paper to create a montage that includes all of the following colours: cyan, 
magenta, yellow, red, green, blue and black. This experience gives better results if, instead of the 
white sheet of paper, the filters are mixed on the plate of an old overhead projector or on a light table. 
It also requires good quality coloured filters, like the ones that are used in theatre stage lighting. Filters 
with the required characteristics can also be obtained by printing the desired colours on a transparent 
acetate paper using a good quality printer. Children can also place different colour objects or draw 
coloured patterns on white paper and observe them through coloured filters. 

Activities related with colour subtraction that are based on the exploration of children’s books are 
described in the next sections. 

2.2.1 Exploring Colours with Children Books and RGB art 
In the last five years, there has been a significant increase in the publication of children’s books whose 
coloured illustrations are created in such a way that the reader can see different images depending on 
whether he read the book with or without the coloured filters that come with it. This allows children’s to 
discover different stories within the same book, only by changing the colour of the filter they use to 
read the book. These beautifully illustrated books are fascinating not only because they can be used 
to develop and promote a taste for reading among children's and youngster´s, by making reading 
enjoyable, but also because they provided a stimulating environment for children’s to discover and 
explore colour phenomena. 

There are some key ideas about colour that can be explored using these books, namely: 

a) Light is necessary to see the world around us. To see an object, light must fall on it and then be 
reflected or transmitted from the object to our eyes. 

b) The colour in which we perceive an object is not an intrinsic property of the object but rather a 
subjective phenomenon that depends on the composition of light illuminating the object, on the 
characteristics of the material that the object is made from and on the physiological and 
psychological features of the human visual system. 
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c) The colour of objects that do not produce light is usually the result of a color 
subtraction process: the object absorbs (or subtract) some colours from incident light and only 
reflect or transmit the remaining colour(s) to the viewer’s eyes. 

d) The colour in which we perceived an opaque object depends on the composition of the light it 
reflects to our eyes, while the colour in which we perceived a transparent object depends on the 
composition of the light it transmits to our eyes. 

e) The colour in which an object is perceived may change depending on the colour of the light 
illuminating it. 

A list of some books that can be used by teachers to design learning activities related with colours in 
preschool and primary education can be found in the references.  

In the the books “Mi hermano pequeño invisible” by Ana Pez [7] and “The great journey” by Agathe 
Demois and Vincent Godeau [1] the coloured illustrations are composed by only two colours: red (or 
orange) and cyan. Both books come with a red filter that allows us to see, in each coloured illustration, 
two different images depending on whether the book is illuminated with white light or view through the 
coloured filter. Fig.2 shows how one of the coloured illustrations of the book “Mi hermano pequeño 
invisible” is perceived without and with the red filter. 

 
Figure 2. Cover of the book “Mi hermano pequeño invisible” (a) and the two images that can be seen in the 
same page, depending on whether the book is illuminated with white light (b) or view through a red filter (c). 

The white pigments (under white light) that compose the picture reflect the light colours red, green and 
blue. If we put a red filter (under white light) in front of the white pigments, the filter absorbs the green 
and blue lights and transmits only the red light. So, the white pigments are perceived as red when we 
look to them through the red filter. The red pigments (under white light) absorbs the light colours green 
and blue and reflect the colour red. If we look to the red pigments through the red filter, the colour 
perceived is red because the filter transmits the red light to our eyes. Both white and red pigments are 
perceived as red when view through the red filter. The cyan pigments (under white light) reflect the 
light colours green and blue and absorbs the colour red. If we look to the cyan pigments through the 
red filter, the pigments are perceived as black because the red filter absorbs both green and blue 
lights. 

 
Figure 3. Carnovsky’s RGB image and the three layers in which the image is composed. 

(a)  
(b)  (c)  
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The books [5], [6], are based on the work by Francesco Rugi and Silvia Quintanilla, an art and design 
duo based in Milan, also known by the name of “Carnovsky”, whose creations range from design to art 
to fashion [12]. This Italian duo employ a technique, known as RGB, based in additive colour theory to 
create multi-layered images which reveal different scenes when viewed through filters or lights of the 
three primary additive colours (red, green, and blue) (Fig. 3). Carnovksy´s RGB technique consists in 
the overlapping of three totally different images, each one in a primary additive colour and each one 
composing a layer of the final image. The colours of the superposed images mix up to create the cyan, 
magenta and yellow colours that we can see in the final image. Using red, green and blue filters or 
lights it is possible to see clearly the different layers that compose the image. Each primary light colour 
interacts with the final image unveiling one of the three layers: the red light reveals the red layer, while 
the green light brings out the green layer and the blue light shows the blue layer (hence the RGB 
name). On Carnovsky’s website it is possible to access an application that can be used on mobile 
devices, provide such devices support camera access from a browser, that turn the device’s lens into 
a coloured filter. Using this application, for example on a mobile phone, allow us to see the three 
different layers that composed a Carnovsky RGB image. 

The explanation of the perceived colours of the RGB image shown in Fig. 3, when illuminated with red, 
green and blue light, is giving in Fig. 4 using the ATC (addition table of colours) model, [10], [13]. This 
model unite additive and subtractive colour mixing in one single equation that explains the colours 
perceived when coloured objects are illuminating by different coloured lights. The equation for a 
particular colour combination is built by attributing the plus signal (+) to light sources and the minus 
sign (-) to filters or light absorbing objects. 

 
Figure 4. Explanation, with the ATC model of the perceived colours of the RGB image  

shown in Fig.3 when illuminated with red light. 

 

What does the cyan pigments look like when illuminated with red light? 
RED LIGHT = + RED 
CYAN PIGMENTS = - RED 
PERCEIVED COLOUR = + RED - RED = NO LIGHT (perceived as black) 
 
What does the magenta pigments look like when illuminated with red light? 
RED LIGHT = + RED 
MAGENTA PIGMENTS = - GREEN 
PERCEIVED COLOUR = + RED - GREEN = + RED (perceived as red) 
  
What does the yellow pigments look like when illuminated with red light? 
RED LIGHT = + RED 
YELLOW PIGMENTS = - BLUE 
PERCEIVED COLOUR = + RED - BLUE = + RED (perceived as red)  

 

What does the cyan pigments look like when illuminated with green light? 
GREEN LIGHT = + GREEN 
CYAN PIGMENTS = - RED 
PERCEIVED COLOUR = + GREEN - RED = + GREEN (perceived as green) 
 
What does the magenta pigments look like when illuminated with green light? 
GREEN LIGHT = + GREEN 
MAGENTA PIGMENTS = - GREEN 
PERCEIVED COLOUR = + GREEN - GREEN = + NO LIGHT (perceived as black) 

 
What does the yellow pigments look like when illuminated with red light? 
GREEN LIGHT= + GREEN 
YELLOW PIGMENTS = - BLUE 
PERCEIVED COLOUR = + GREEN - BLUE = + GREEN (perceived as green)  

 

What does the cyan pigments look like when illuminated with blue light? 
BLUE LIGHT = + BLUE 
CYAN PIGMENTS = - RED 
PERCEIVED COLOUR = + BLUE - RED = +BLUE (perceived as blue) 
 
What does the magenta pigments look like when illuminated with blue light? 
BLUE LIGHT = + BLUE 
MAGENTA PIGMENTS = - GREEN 
PERCEIVED COLOUR = + BLUE - GREEN = + BLUE (perceived as blue) 

 
What does the yellow pigments look like when illuminated with blue light? 
BLUE LIGHT = + BLUE 
YELLOW PIGMENTS = - BLUE 
PERCEIVED COLOUR = + BLUE - BLUE = NO LIGHT (perceived as black)  
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2.2.2 Creating a RGB image with GIMP 
A Carnovsky’s RGB image type can be created by combining three black and white images in a photo 
editing software. In this section we present a simple tutorial that shows how to do it using the open 
source image editor GIMP (GNU Image Manipulation Program) [14] and the three black and white 
images that are shown in Fig. 7, [15]. It is convenient that the images have the same size in pixels. 
Teachers can use this tutorial to create RGB images using black and white draws made by the 
students. It is only necessary to digitalize these draws so they can be manipulated on a computer 
using a photo editing software. 

First is necessary to install the image editor GIMP on a computer. Since the “Colourify” filter, which we 
are going to use to add colour to the images, are no longer available on the latest version of GIMP 
(2.10.10), we are going to work with the former version 2.6.11. 

The first step is to open the image editor GIMP on the computer. Once the program is open, the next 
step is to load the three images. To do this, go to File>Open, select all the images at once and click 
the Open button. When loaded, the images will open in separate windows. 

Now we have to add colour to the images. We begin with the image for the red layer (the order in 
which the images are colourized is irrelevant). Select the image, go to Image>Mode>RGB and then to 
Filters>Colors>Colorify. A window appears with coloured thumbnails, as shown in Fig.5. Because this 
is the red layer image, click on the red thumbnail. The preview of the image will turn from black and 
white to red. Now click the OK button. Do the same for the other two images, which are going to 
compose the green and blue layers, using the green and blue thumbnails, respectively. 

 
Figure 5. GIMP´s Colorify window with the preview of the red layer image. 

Once colour has been added to the images, they can be combined to form a colour image. First we 
have to make sure that the Layers window is open. If it is not open, click on any of the three images 
and go to Windows>Dockable Dialogues>Layers. The small thumbnail in the Layers window will 
change colour depending on the colour of the image that has been selected – in this example the 
selected image is the red one, as can be seen in Fig. 6a. To combine the three images, we simply had 
to copy and paste them on top of each other using any one as the base. In this example, the base is 
the red image. So, click on the green or blue image (in this example, we begin with the green image), 
go to Select>All and then to Edit>Copy. Now, click on the red image again and go to Edit>Paste. In 
the red image’s layer window a new layer, called Floating Selection (Pasted Layer), has appeared 
(Fig. 6b). Double click over the icon of that layer and will get the option to rename it. In this example, 
since the image that has been paste is the green layer image we called the new layer as Green. The 
thumbnail will then change and shows a green preview (Fig. 6c). Now, click on the blue image, go to 
Select>All and then to Edit>Copy. Go back to the red image, that now shows the green image on top 
of it, and go to Edit>Paste. Rename the new Floating Selection as Blue (Fig. 6d). 
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Figure 6. Creating the three layered image in GIMP. 

Now we have the three images layered up but we have to change the layers blend mode in order to be 
able to see through each of them. To accomplish this, we have to click on each layer icon and change 
the layer blend mode from Normal to Screen. The final RGB image is ready and is shown in Fig.7. 

 
Figure 7. Black and white images used to create an RGB image, the red,  

green and blue image layers and the final RGB image. 

 

(a) 

 

(b) 

 

(c) 

 

(d) 
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3 CONCLUSIONS 
With this work the authors intend to contribute for teaching of the colours more cleared up. The 
proposed activities are easily implemented and can be adapted to any level of education. The 
activities involve the use of coloured shadows to learn about mixing additive colours, the use of light 
filters to learn about the subtractive colour mixing and RGB art uses both processes in a creative way. 
However, the educators should take into account that to an undiscerning youngster's eye the colours 
can look different than for a well trained eye. Cyan looks awfully close to blue and magenta looks 
awfully close to red, which often leads learners to misunderstandings. 
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